Balance 50 & VOIP/SIP weighted balance problem


#1

Hi,
We have a peplink balance 50, we have 5 adsl connections (each average 10mb down) to this balancer but I want to seperate the VOIP and Data to use seperate routers (bad users killing download/upload!).

I have tried creating various different outbound policies:
to PBX domain name
to PBX IP address
with source to the voip IP network (10.2.0.0) (Data VLAN is 10.1.0.0 & VOIP vlan is 10.2.0.0)

I have the weighted balance for the VOIP (which is first in the list) of:
10
0
10
10
0

I have the last entry for DATA (catch all) with weighted:
0
10
0
0
10

If I check the active connections I can see that for the IP address of the phone that any service like DNS, TFTP etc go down the correct WAN (1,3,4), but the SIP service always goes down WAN2?

Is there any reason why the SIP service would not follow the outbound policy?

Thanks


#2

Have you tried Overflow rule from WAN 1-2-3 for the VoIP network? And keeping the weighted balance policy for the data network? What firmware? I would use the latest 6.2.0. Is the Service Pass through for SIP in compatibility mode? And are you double natting all your WAN’s? If so I would put all modems into bridge mode for the VoIP network.


#3

Hi,
Thanks for the reply, I will look into each thing you mention, but here are some of the answers I have at mo
Firmware : 6.1.2 build 2717 - I will download the 6.2
Service Pass Through is Standard
Routers are currently standard movistar/vodafone, planning on replacing with draytek voyager 130, for modem only, but I will test these current routers in bridge mode…
Not tried the Overflow…

Thanks again.


#4

No problem and I would put the it in compatibility mode instead of standard mode. Aldo under “applications”, make all supported voip protocols: High and RTP: High.


#5

OK, This morning I:

  • Upgraded to 6.2.0 Firmware
  • Changed Service Passthough to Compatibilty mode
  • Applications - All VOIP and RTP to HIGH
  • Changed the Outbound Policy for VOIP Network (10.2.0.0/23) to Overflow WAN2, WAN1, WAN3, WAN5, WAN4
  • The above is the first policy

The DNS service for the IPs/phones follows the Overflow rule and all are on WAN2, but the SIP service does not follow the rule and the phones are split between the 5 WANs?

Is there any reason the DNS Service would follow this rule and the SIP service not?

Thanks again for your help.


#6

I am wondering if it is a lease/timeout thing? testing with a phone, if I powered off for 5 minutes then powered the phone back on, it would keep on the same WAN it was on before despite the outbound policy telling it to use a different WAN. I then unplugged the phone for approx 2 hours, when powered on, it used a WAN I would expect it to use based on the outbound policy…


#7
  1. Who is your SIP provider?
  2. How much bandwidth do you have for each adsl circuit, Down/Up?
  3. What codec are the phones using?
  4. What model Phones?
  5. How many phones are on the network?

*You may want to try the priority rule because having the phones all on same WAN is pretty crucial. I recommend overflow just because it sounds like you don’t have much bandwidth and I assumed you have more than 10 VoIP phones on the network. Reason being is because from my understanding the overflow rule takes place when the WAN is in roughly 90% of use and “assuming” you have low bandwidth but high volume of phones, it seemed like best option, but again my assumption may have been wrong. Def need more details of the network.


#8

Also, you can try opening inbound on the firewall ports 5060-60000 from your SIP providers feature server and make the destination your phone network. And on outbound policy make the source your phone network, make the destination either the domain or IP of your feature server, UDP, and port 5060.


#9

Hi tjvoip45,
Just to say thanks for your suggestions and to give a little feedback.

  • 6.2.0 Firmware
  • Service Passthough to Compatibilty mode
  • Applications - All VOIP and RTP to HIGH
  • Split 2 routers for VOIP and 3 routers for DATA, weighted balance
  • Disconnected Cisco phones for approx 1 hour

Not the Peplink is behaving how I expect it to behave and ‘seems’ to be a lot better with the low upstream each adsl has.

Thanks for your time providing help/suggestions, it was appreciated.

Have another 2 peplink balance 50’s coming shortly to try and manage another 10 adsl lines better :slight_smile:


#10

Forget to mention, I just received a Draytek Vigor 130 so I will be testing that on the peplink in place of some of the movistar/vodafone routers, if if works well, will look to replace all 15 routers…


#11

No problem, good luck with everything.