Balance 30 NAT Mapping for Remote Printing


#1

Dear all,

Our company has an MPLS VPN that connects the main site (lets call it A) and a branch office (B). Before buying the Peplink for B, the local computers on B were connected to the VPN through a Thomson TG585v8 gateway provided by the ISP hosting the VPN. The company decided to buy a multi-wan router for Office B which would host the VPN line and 2 more ADSL lines for internet use. The setup looks something like this:
Office A LAN —> Gateway —> ISP Backbone —> Thomson TG585 Gateway (provided by the ISP) —> Peplink Balance 30 —> Office B LAN

Computers in Office B are using a CRM and an Ordering application which run via a Remote Desktop connection (RDP) from office A (don’t ask me why…). When running the RDP from B to connect to A, print jobs from the ordering application must be sent to the main printer of Office B which is attached to the Domain Controller of B.
Our problem is that since Office B is now behind a NAT, Office A cannot see B’s LAN, thus the printer cannot be shared to the remote location. In other words, the printer from Office B needs to be shared to Office A. How can this be done?
How about if I NAT map the domain controller’s (i.e. the computer where the USB printer is located) IP to the WAN1 interface IP (OR the gateway’s public IP?), so then I could share the printer to the remote location using the Interface IP (or GW’s public IP) instead of the domain controller’s local IP.
Is this the way to do it? If yes, is it as simple as just mapping the GW’s public IP to the said private IP? Any other suggestions?

Thanks in advance,
KD


#2

You may be able to accomplish this with the proper port forwarding or NAT mapping configuration; however we would recommend a drop-in mode deployment for this scenario which requires a Balance 210/310 model or above.


#3

First off, thanks for your reply.
I’m not sure if upgrading to a 310 model is an option. It is not up to me to decide.

As shown in the image below, I tried mapping the private IP of the DC to Peplink’s WAN1 Interface IP and to the WAN IP of the Gateway, but with no luck so far. If it had worked, then at least wouldn’t I be able to ping or access the DC (\dcIPaddress](file://\dcIPaddress))? Could you elaborate on how this could be done?
Something else I noticed is that I cannot ping the WAN1 Interface IP from Office A, although the ‘Reply to ICMP’ option is enabled. Any thoughts?.

Again, thanks in advance.
KD