Balance 20-Multiple wired devices offline

I recently updated the IP Range and IP Address of the untagged network in my Balance 20. In doing so I now have multiple devices that will not connect to the wired network. These include 2 Roku devices, 1 Global Cache IP2SL and a Tablo DVR. The 2 Roku devices will connect wirelessly along with the Tablo but will not connect wired. All devices show up in the client list and that they have been issued a new IP address but they show offline. Interestingly when I go into the Roku’s “about” info it shows an IP address of I tried going back to the old IP range and that didn’t work as well.

Does anyone have suggestions or tips on this?

Thank you in advance,

Off hand I would say it sounds like the client devices are confused by the new IP addressing and need a reboot. If that doesn’t work then try rebooting the Balance 20.

If that doesn’t work try turning off the client devices completely by removing power to them and then rebooting the Balance 20. Log in and navigate to the client list page. Then turn on one device at a time and verify they are appearing on the list and being assigned IP addresses correctly.

If the ROKU’s still can’t connect then verify that the Balance 20 DNS settings are pointing to valid DNS servers or obtaining them automatically. Try doing a DNS leak test and see what it says.

If that doesn’t work then this time try turning off all networked computers/devices/AP’s attached to the Balance 20. Be wary of any devices that don’t actually fully power down - they would have to have a forced shut down or be unplugged. Then reboot the Balance 20, log on and navigate to the client list page. Then turn on your AP’s one by one. Then turn on one client device at a time and verify they are appearing on the list and being assigned IP addresses correctly.

Log in to the Balance 20 and make sure LAN>port settings are “trunk”, “VLAN>any”, for the device’s that still can’t connect. (Please correct me if I am wrong on this as I am still learning) You could also try turning on UPnP (if it isn’t already).

At this point a client that won’t connect probably needs a hard reset/factory reset via the little hidden button on the back. This will probably erase user settings so be warned. On the ROKU Ultra it’s on the bottom of the unit. You can also reset the ROKU via the user menu by going to Advanced Settings>Factory Reset>PIN. Just do one of the ROKU’s to speed up testing/see if it works.

Hope that helps! :speaking_head:

1 Like

Hi HappySurfer,

I tried all of the above options. Not one of them worked. I finally did a factory reset on the Balance 20. Initially I was able to get the one of the two Rokus and the Tablo to connect via a hard wired connection. After about a couple of hours it was no longer working again. The second Roku never came back on via hard wire after the factory reset.

One more issue I’m finding as well. I have two Bluesound streaming music players. Both are able to connect and stream music from the internet. I’m able to connect to my local server but am unable to access the music files on that server.

Thanks in advance,

I am sorry to hear that. It almost sounds like you suffered equipment damage due to a lightning strike (or power surge) to have that many problems simultaneously. Try swapping in a new power bar - I have seen them malfunction after taking power surges.

On the other hand ROKU’s don’t last forever. Verify that you do not have any large inductive loads on the same electrical circuit as those entertainment devices (ie. fridge, microwave oven, airconditioner, power tools). Lights dimming when a large inductive load starts up is a big give away.

Try testing the entertainment devices one by one to try to isolate a bad or malfunctioning unit. Also try different LAN ports on the Balance and verify you get an orange and green light on the LAN port when plugged in and powered up. Verify none of the LAN ports on the Balance are damaged by plugging known good devices into them.

If you have an old router laying around, use it to test these entertainment devices to establish where the problem lies. Do this one device at a time to establish whether it works or not and if it does then connect another one for test.

If one of the devices is outputting garbage onto the LAN it will crash/slow down the local area network and negatively impact other devices connectivity. Isolate the devices to establish whether they work or not.

The ROKU’s (and other devices) may be warranty claims / RMA at this point if they don’t work on 2 different routers or time to get new ones/upgrade. Call them because they might offer you a deal if you are subscribed to a lot services / valuable customer etc…

I have also heard of ISP’s having NAT (and/or traffic shaping) that interferes with streaming devices and services. You may want to contact them to see if they changed anything on their end or try doing some internet searches with their name and the malfunctioning devices in the search terms: “ROKU/Bluesound streaming problems with ISP”. If nothing is on a VLAN then your LAN computers should be able to see it (turn VLAN off on the ports under network settings etc.).

Anyhow I feel your pain. I just bought a new modem and its crashing my SURF every 4-8 hours no matter how I configure it. I googled it and found lots of people having problems with it that they could not resolve. No wonder it was so cheap! Plugged the old one back in and smooth sailing. Good times.

1 Like

So, what I tried is this. I bypassed the Balance 20 and did a direct connect to one of my ISP Modem/Router. Everything now works as it did. This tells me that there is an issue with the Balance 20.

I wished I would have thought to try this initially.

Are there anymore steps I can try to get the Balance working again? I don’t wish to have the replacement cost of a new router.

Thank you,

  1. When I do a factory reset on my SURF I redo all my settings from scratch (do not use a saved config) for best results.

  2. If it still won’t play ball try loading the old firmware, then a factory reset and then redo your settings from scratch.

  3. Just do a quick test for the malfunctioning devices in question (ie. don’t reconfigure the entire network yet).

  4. Try retesting (basic) connectivity with the latest firmware?

  5. If none of that works then it sounds like you need a new router(?) or you still have a faulty client device ruining your LAN connectivity.

  6. Check all the network cables for damage. Swap test.

  7. If you have verified everything works on an old router(s) then you should call your point of purchase for further instructions and see what your options are (warranty/ service repair).

  8. Bonus points: repeat step 2 and load an old known good config.

  9. SURF’s are only $200USD.*

  10. Verify both ISP’s connectivity.

*In the meantime just run your old equipment and see if things run smoothly.


Problem Solved!

I took another look at your comments and looked at this one more closely:

When I was updating the IP range of my untagged network I had selected the “Inter-VLAN Routing” in the untagged network. So, I deselected this. I also had “Trunk” set for Port Type and “Any” set for VLAN. So, I also changed this to Access and Untagged respectively. Applied Changes.

My system is running normal again.

Thank you, HappySurfer!!

1 Like

Good job!

Glad I could help and I learned something too re. streaming devices and VLAN/port settings.

Remember, in the future when experimenting with settings to save your configuration (download) before changing anything so you’ll have a “known good configuration” to go back to (upload) just in case…

System>Configuration>Download Active Configuration>Download/Upload

These products make testing out different ideas / network configurations fast and recoverable in case things don’t work.

1 Like